M茅todos de adopci贸n de dispositivos para controladores UniFi remotos

Este art铆culo describe varios m茅todos diferentes de capa 3 para implementar UAP. Los m茅todos recomendados se encuentran a continuaci贸n en las secciones Navegador web de Chrome y Aplicaci贸n m贸vil.

Configuraci贸n inicial

1. Aseg煤rese de estar familiarizado con c贸mo funciona UniFi (por ejemplo, d贸nde est谩 el AP y el Controlador en la misma L2) antes de intentar la administraci贸n de L3. Tambi茅n recuerda que para adoptar 1. Puerto WAN conectado a Internet.

2. Puerto LAN conectado localmente para acceder a las funciones de administraci贸n en el USG

Nota: Los puntos de acceso de UniFi tienen una URL de informaci贸n predeterminada http: // unifi: 8080 / inform. Por lo tanto, el prop贸sito de usar la opci贸n 43 de DHCP o DNS es permitir que el AP sepa la IP del Controlador.

Navegador web Chrome

Despu茅s de instalar el complemento de la herramienta Discovery (disponible gratuitamente en Chrome Web Store) en su PC de escritorio que ejecuta el navegador Chrome, los dispositivos UniFi no administrados y disponibles localmente (es decir, la misma red L2 que su PC de escritorio) aparecer谩n “Adopci贸n pendiente” para la administraci贸n de L3 a trav茅s de cualquiera de las dos interfaces UniFi listas para la nube: el Tablero de SDN y el Controlador en s铆.

A trav茅s de UniFi SDN Cloud Dashboard

1. Vaya a https://unifi.ubnt.com/ e inicie sesi贸n con sus credenciales de UBNT.

2. Vaya a la secci贸n Dispositivos y localice el modelo con el estado de Adopci贸n pendiente. Haga clic en ADOPTAR.

3. En la ventana Adoptar que aparecer谩, seleccione el Controlador y el Sitio que adoptar谩 el dispositivo y haga clic en Adoptar.

A trav茅s del controlador UniFi Cloud

1. Inicie el Controlador UniFi, vaya a la secci贸n Dispositivos, busque el dispositivo que desea adoptar con el estado “Adopci贸n pendiente – Detectado localmente” y haga clic en Adoptar en Acciones.

Aplicaci贸n movil

1. Despu茅s de instalar la aplicaci贸n UniFi Mobile (disponible gratuitamente en la tienda de aplicaciones iOS y Android Play Store), inicie la aplicaci贸n y toque Acceso directo (en iOS, en Android ver谩 la secci贸n Acceso directo en la pantalla una vez que inicie la aplicaci贸n , ver im谩genes abajo).

NOTA: su dispositivo m贸vil debe estar conectado a la misma red que sus dispositivos y debe poder acceder al Controlador directamente (mediante HTTP). Puede ser necesaria una IP p煤blica y / o reenv铆o de puertos. El puerto de informaci贸n del controlador debe ser 8080.

2. Seleccione su controlador de la lista, o toque el bot贸n “+” para iniciar sesi贸n y agregar su controlador.

3. Para iOS: una vez que haya iniciado sesi贸n en el Controlador, toque M谩s. Aqu铆 ver谩 la opci贸n de Adopci贸n de Capa 3 en Utilidades. Para Android: toque el men煤 de “hamburguesas” de tres l铆neas y despl谩cese hacia abajo hasta que vea Adopci贸n L3 en Utilidades.

4. Los dispositivos se mostrar谩n en esta pantalla. Toque el dispositivo que desea adoptar y seleccione Adoptar.

5. Despu茅s de unos segundos (15-30 segundos, los tiempos variar谩n) el dispositivo aparecer谩 en la secci贸n Dispositivos, al que puede acceder haciendo clic en el icono Dispositivos en la barra de men煤 inferior.

Utilidad Discovery

No muchos entornos pueden tener un servidor DHCP que sea configurable, incluso menos probable con un servidor DNS. Ah铆 es donde entra en juego la Utilidad de descubrimiento de UniFi. Escucha los paquetes de multidifusi贸n / difusi贸n de los puntos de acceso de UniFi y le permite configurar el AP para informar cualquier URL que desee. (solo se mostrar谩n los AP en un estado predeterminado o que no est茅n en contacto con ning煤n Controlador)

La utilidad UniFi Discovery se instala junto con su Controlador UniFi.

  • En Windows, est谩 en Men煤 Inicio-> Ubiquiti UniFi-> UniFi-Discover
  • En Mac, /Applications/UniFi-Discover.app (o use Spotlight para encontrarlo)
  • Ejecute “java -jar <unifi_base> /lib/ace.jar discover”

Para realizar la adopci贸n de L3 con la utilidad de descubrimiento:

1. Espere hasta que aparezca el AP

2. Si el AP no est谩 en un estado predeterminado. haga clic en “restablecer”, especifique el nombre de usuario / contrase帽a de SSH y haga clic en “Aplicar”

3. Haga clic en “administrar”, modifique la URL de informaci贸n y deje el nombre de usuario / contrase帽a de SSH como ubnt / ubnt y haga clic en “Aplicar”

4. Abra un navegador en su controlador UniFi remoto y ver谩 que est谩 “Pendiente de aprobaci贸n”

5. Haga clic en “adoptar”. Ver谩 que va al estado “Adoptando”, ign贸relo ya que eventualmente se convertir谩 en “Adopci贸n fallida” o “Desconectado”

6. Perform [step 3] again (no need to wait for [step 5] to finish)

7. AP ahora es administrado por el controlador. Una vez adoptado, el Controlador actualizar谩 estas unidades autom谩ticamente.

NOTA: Si su controlador L3 est谩 disponible a trav茅s de la WAN, debe asegurarse de que los puertos necesarios est茅n abiertos en el lado del controlador (puerto m铆nimo 8080 para informar). Si no tiene una IP est谩tica, puede considerar usar un servicio de DNS din谩mico y usar el nombre de dominio en lugar de la IP para la direcci贸n de informaci贸n. Si est谩 utilizando un USG, puede usar el cliente DDNS que est谩 disponible en ese dispositivo.

DNS

Deber谩 configurar su servidor DNS para resolver ‘unifi’ a la direcci贸n IP de su controlador. Aseg煤rese de que AP pueda resolver el nombre de dominio del controlador. Por ejemplo, si est谩 configurando http: // XYZ: 8080 / inform, haga ping desde AP para determinar si XYZ se puede resolver / alcanzar.

Soluci贸n de problemas: el AP (con IP est谩tica) no se puede conectar al controlador L3:

  • Al configurar un AP de DHCP a est谩tico en la interfaz de usuario del controlador, aseg煤rese de haber puesto la IP del DNS. Si no, el AP no puede ponerse en contacto con DNS para resolver el nombre de dominio del Controlador.
  • Si se ha restablecido el AP (presionando el bot贸n de reinicio), aseg煤rese de haber informado a AP dos veces (utilizando la utilidad de descubrimiento) sobre la ubicaci贸n del Controlador (esto se mejorar谩 en la pr贸xima versi贸n 2.3.0)

Opci贸n DHCP 43

Si utiliza los enrutadores EdgeMAX de Ubiquiti, entonces la opci贸n 43 de DHCP se puede hacer ingresando la direcci贸n IP del Controlador UniFi en el campo “unifi” en el servidor DHCP.

NOTA: UniFi Security Gateway (USG) no utilizar谩 la opci贸n 43 de DHCP para agregar la ubicaci贸n del Controlador UniFi cuando obtenga una concesi贸n DHCP en la interfaz WAN.

Para utilizar la opci贸n 43 de DHCP, deber谩 configurar su servidor DHCP. Por ejemplo:

Servidor DHCP de Linux ISC: dhcpd.conf

# …

option space ubnt;

option ubnt.unifi-address code 1 = ip-address;

class “ubnt” {

        match if substring (option vendor-class-identifier, 0, 4) = “ubnt”;

        option vendor-class-identifier “ubnt”;

        vendor-option-space ubnt;

}

subnet 10.10.10.0 netmask 255.255.255.0 {

        range 10.10.10.100 10.10.10.160;

        option ubnt.unifi-address 201.10.7.31;  ### UniFi Controller IP ###

        option routers 10.10.10.2;

        option broadcast-address 10.10.10.255;

        option domain-name-servers 168.95.1.1, 8.8.8.8;

        # …

}

Cisco CLI

# assuming your UniFi is at 192.168.3.10

ip dhcp pool <pool name>

network <ip network> <netmask>

default-router <default-router IP address>

dns-server <dns server IP address>

option 43 hex 0104C0A8030A # 192.168.3.10 -> CO A8 03 0A

# Why 0104C0A8030A ?

#

# 01: suboption

# 04: length of the payload (must be 4)

# C0A8030A: 192.168.3.10

Mikrotik CLI

/ip dhcp-server option add code=43 name=unifi value=0x0104C0A8030A

/ip dhcp-server network set 0 dhcp-option=unifi

# Why 0104C0A8030A ?

#

# 01: suboption

# 04: length of the payload (must be 4)

# C0A8030A: 192.168.3.10

Cisco tiene una buena redacci贸n para la configuraci贸n de la opci贸n 43 de DHCP. Tambi茅n puede usar la IP del controlador en la URL de informaci贸n en lugar del nombre de dominio.

SSH

Si puede SSH en el AP, es posible hacer una adopci贸n de L3 a trav茅s del comando CLI

  1. Aseg煤rese de que el AP est茅 ejecutando el firmware actualizado.
  2. Aseg煤rese de que el AP est茅 en el estado predeterminado de f谩brica. Si no lo es, haz:sudo syswrapper.sh restore-default
  3. SSH en el dispositivo y escriba lo siguiente y pulsa enter:set-inform http://ip-of-controller:8080/inform
  4. Despu茅s de emitir el set-inform, el dispositivo UniFi se mostrar谩 para su adopci贸n. Una vez que haga clic en adoptar, el dispositivo aparecer谩 desconectado.
  5. Una vez que el dispositivo se desconecte, ejecute nuevamente el comando set-inform en el paso 3. Esto guardar谩 permanentemente la direcci贸n de informaci贸n, y el dispositivo comenzar谩 el aprovisionamiento.

NOTA: El comando set-inform se debe emitir dos veces. De lo contrario, el dispositivo se desconectar谩 despu茅s de que parezca adoptar. El proceso a seguir es:

  1. Ejecute el comando set-inform en el paso 3 anterior.
  2. El dispositivo aparecer谩 listo para su adopci贸n en el Controlador. Haga clic en Adoptar.
  3. Espere a que aparezca el estado ‘Adoptando’ en el Controlador UniFi, luego ejecute nuevamente el comando set-inform.
  4. El dispositivo ahora deber铆a cambiar a un estado de ‘Aprovisionamiento’ y luego conectarse poco despu茅s.